Tableurs : travailler avec des noms

mardi 28 janvier 2014, par ID

Contrairement à ce qu’affirment les personnes qui utilisent des tableurs sans savoir s’en servir, ces logiciels ne font pas d’erreurs de calcul, ils se contentent de faire ce qu’on leur demande de faire. Encore faut-il, par exemple, vérifier que les éléments donnés en référence des formules sont les bons. L’un des outils dont on dispose est le « Nom ». Cette fonction permet d’attribuer un nom à une cellule ou une plage de cellule.

 L’intérêt ?

  1. L’usage des noms rend les formules plus lisibles et, souvent plus courtes ; plus elles sont complexes, plus cela devient nécessaire.
  2. Cela permet d’une certaine façon de « documenter » la formule, c’est-à-dire de donner des informations plus concrètes (à condition que le nom soit bien choisi et parlant) sur sa construction.
  3. La formule est aussi plus facile à contrôler et à corriger, car il suffit de corriger la plage si nécessaire sans toucher à la formule.
  4. On peut même ainsi plus facilement utiliser la même formule ailleurs.
La formule comporte deux noms « affectation » et « ht »
Dans les deux cas les informations sont sur une autre feuille.

 Création (insertion) d’un nom

Sélectionner la ou les cellules.

Dans Calc : aller dans Insertion/Nom puis sur Définir. Dans les options de plage, on peut définir la sélection comme zone d’impression.

Avec Excel, depuis 2007  : onglet Formule/Définir un nom.

Bien vérifier la plage sélectionnée
On pourra toutefois la corriger par ailleurs.

Dans les deux cas, le nom doit impérativement ne comporter que des lettres sans caractères dits spéciaux (lettres accentuées, cédilles…) ou des chiffres et aucune ponctuation ni espace. Si on veut avoir des lettres et des chiffres, il est indispensable de les séparer par un tiret de soulignement, sinon les tableurs ne l’acceptent pas.Les plages nommées sont des références absolues comme on peut le voir aux $ dans les références. À cette étape il est utile de vérifier l’étendue des cellules sélectionnées. Il sera néanmoins toujours possible de modifier cette plage en passant par le menu Insertion/Nom/Gérer de Calc ou par le Gestionnaire de noms d’Excel.

 Utiliser dans une formule

L’utilisation des noms dans une formule est simplissime : il suffit de taper exactement le nom quand on saisit la formule. Et si on s’est trompé dans le nom, on peut toujours le modifier par la suite.

Avec Excel, lorsque l’on met en place une fonction on peut aussi, en cliquant sur les boutons à droite de la zone de saisie dans les formules accéder au bouton Utiliser dans formule de l’onglet Formule pour sélectionner le nom dans la liste de ceux définis dans le classeur.

Somme.si dans Excel
Insertion d’un nom dans la fonction somme.si avec Excel.

C’est également possible depuis avec OpenOffice et LibreOffice.

Utiliser les plages dans Calc
Dans Calc on tape le nom directement ou l’insère via le menu ad hoc.

Dans l’exemple ci-dessous, il s’agissait, dans un QCM, de délivrer un message en fonction du résultat, la formule utilisant des noms : =SI(C4=C3; bon; erreur)

et sans : =SI(C4=C3;"Bravo, vous avez donné la bonne réponse »;"Désolé, vous vous êtes trompé.").

Dans les deux cas, la formule renvoie le même message, mais celui-ci peut être facilement (et confortablement) corrigé dans sa cellule d’origine avec l’avantage que la correction ne sera nécessaire qu’une seule fois alors que, dans l’exemple, il faudrait effectuer la correction partout où la formule est présente dans le tableau. Et encore, ici il ne s’agit que d’un exemple textuel...